Real Customer Supportbypass navigation Customer Support

RealNetworks, Inc. Releases Update to Address Security Vulnerabilities.

Updated November 10, 2005

RealNetworks, Inc. has addressed recently discovered security vulnerabilities that offered the potential for an attacker to run arbitrary or malicious code on a customer's machine. RealNetworks has received no reports of machines compromised as a result of the now-remedied vulnerabilities. RealNetworks takes all security vulnerabilities very seriously.

Affected Software: (see BLUE below)

Windows
Software Affected? Language Update Available?
RealPlayer 10.5 (6.0.12.XXXX) No All supported Not required
RealPlayer 10.5 (6.0.12.1040-1235) By All All supported Yes
RealPlayer 10 By All All supported Requires upgrade
RealOne Player v2 By #2 & #3 All supported Requires upgrade
RealOne Player v1 By #2 & #3 English Requires upgrade
RealPlayer 8 By #2 & #3 All supported Requires upgrade
RealPlayer Enterprise By #2 English Yes

Note: To see your Player version number (6.0.x.xxxx), select Help > About in the Player menus.


Software Affected? Language Update Available?
Rhapsody 3 (build 0.815 - 0.1141) No All supported Not required
Rhapsody 2 No All supported Not required

Note: To see your Rhapsody version number (build 0.xxx), select Help > About in the Rhapsody menu.


Mac
Software Affected? Language Update Available?
Mac RealPlayer 10 (10.0.0.305 - 331) By #2 All Supported Yes
Mac RealOne Player No English Requires upgrade

Note: To see your Player version number (10.0.0.xxx), select About in the RealPlayer menu.


Linux
Software Affected? Language Update Available?
Linux RealPlayer 10 (10.0.6) No All Provided Not required
Helix Player (10.0.6) No All Provided Not required
Linux RealPlayer 10 (10.0.0 - 5) By #2 All Provided Requires upgrade
Helix Player (10.0.0 - 5) By #2 All Provided Requires upgrade

Note: To see your Player version number (10.0.0.xxx), select Help > About in the Player menu.


Handheld Devices
Software Affected? Language Update Available?
Nokia Series60 Handsets No English Not Required
RealPlayer for Palm No English Not Required
RealOne Player for Palm No English Not Required

Workaround:

To ensure that your Player is protected, we recommend installing the available updates:

UPDATES

Windows Players:

RealPlayer 10.5 customers pleaseclick here or use the following steps to upgrade your Player:

  1. In the Tools menu select Check for Update.
  2. Select the box next to the "Security Update - November" component.
  3. Click Install to download and install the update.

RealOne Player (English only), RealOne Player V2, and RealPlayer 10 require a full download to correct this issue. Please click here or use the following steps to upgrade your Player:

  1. In the Tools menu select Check for Update.
  2. Select the box next to the "RealPlayer 10.5 with Harmony™ Technology" component.
  3. Click Install to download and install the update.

RealPlayer 8 (version 6.0.9.584) please click here or use the following steps to upgrade your Player:

  1. Go the Help menu
  2. Select Check for Update.
  3. Select the box next to the "RealPlayer 10.5 with Harmony™ Technology" component.
  4. Click Install to download and install the update.

RealPlayer Enterprise Solution:

Please click here to get a patch for your RealPlayer Enterprise.

Mac Players:

RealPlayer 10 for Mac OS X customers please use the following steps to update your Player:

  1. Go the RealPlayer menu.
  2. Choose Check for Update.
  3. Select the box next to the "Security Update - November 2005" component.
  4. Click Install to download and install the update.

RealOne Player for Mac OSX customers need to upgrade to RealPlayer 10 for Mac OSX and then apply the update to address this security issue. Please click here to upgrade your Player. Afterwards, please follow the steps outlined above for RealPlayer 10 to get this additional update.

Linux Players:

Please click here to get an updated RealPlayer 10 for Linux.
Please click here to get an updated Helix Player for Linux.

Exploit Specifics:

  • Exploit 1: To fashion a malicious skin file to cause a stack overflow which could have allowed an attacker to execute arbitrary code on a customer's machine.
  • Exploit 2: To fashion a malicious RealMedia file which could have caused stack overflow to allow an attacker to execute arbitrary code on a customer's machine.
  • Exploit 3: To fashion a malicious skin file to cause a stack overflow which could have allowed an attacker to execute arbitrary code on a customer's machine. The buffer overrun was designed to occur in a 3rd-party compression library.

German
English
Spanish
French
Italian
Portuguese
Japanese
Korean
Simplified Chinese
Traditional Chinese

Acknowledgements:

RealNetworks would like to acknowledge John Heasman of NGS Software, and eEye Digital Security for bringing these exploits to our attention as well as those who subsequently worked with RealNetworks to correct the vulnerabilities.

Warranty:

RealNetworks Inc. endeavors to provide you with the highest quality products and services, but cannot guarantee, and does not warrant, that the operation of any RealNetworks product will be error-free, uninterrupted or secure. Please see your original license agreement for details of our limited warranty or warranty disclaimer.