Real Customer Supportbypass navigation Customer Support

RealNetworks, Inc. Releases Update to Address Security Vulnerabilities.

Updated October 25, 2007

RealNetworks is making available product upgrades that contain security bug fixes. We have received no reports of any machines actually compromised as a result of the now-remedied vulnerabilities.

RealNetworks recommends that if you have installed a product version listed in the table below, you upgrade your product to the current version of the product.


Affected Software: (Please see below for details of potential vulnerabilities)

Windows
Software Affected? Language Update Needed?
RealPlayer 11 No All Supported No
RealPlayer 10.5 (6.0.12.1662) * No All Supported No
RealPlayer 10.5 (6.0.12.1040-6.0.12.1578, 6.0.12.1698, 6.0.12.1741 By various All Supported Yes
RealPlayer 10 By all All Supported Yes
RealOne Player v2 By all All Supported Yes
RealOne Player v1 By #1, #2, #3, #5, & #6 English Yes
RealPlayer 8 By #2, #5 All Supported Yes
RealPlayer Enterprise By #1, #2, #3, #4 & #5 English Yes

Note: To see your Player version number (6.0.x.xxxx), select Help > About in the RealPlayer menu.


* due to Windows Vista compatibility issues, version numbers are now not sequential for RealPlayer 10.5

Software Affected? Language Update Needed?
Rhapsody 4 No All Supported No

Note: To see your Rhapsody version number (build 0.xxx), select Help > About in the Rhapsody menu.


Mac
Software Affected? Language Update Needed?
Mac RealPlayer 10.1 (10.0.0. 503) No All Supported No
Mac RealPlayer 10.1 (10.0.0. 481) By #5 All Supported No
Mac RealPlayer 10.1 (10.0.0.396 - 10.0.0.412) By #2, #3, #4 & #5 All Supported No
Mac RealPlayer 10 (10.0.0.352) By #2, #3, #4 & #5 All Supported No
Mac RealPlayer 10 (10.0.0.305 - 331) By #2, #3, #4 & #5 All Supported Yes
Mac RealOne Player By #2, #3, #4 & #5 English Yes

Note: To see your Player version number (10.0.0.xxx), select About in the RealPlayer menu.


Linux
Software Affected? Language Update Needed?
Linux RealPlayer 10 (10.0.9) No All Provided No
Helix Player (10.0.9) No All Provided No
Linux RealPlayer 10 (10.0.5 - 10.0.8 By #2, #3, #4 & #5 All Provided Yes
Helix Player (10.0.5 - 10.0.8) By #3 All Provided Yes

Note: To see your Player version number (10.0.0.xxx), select Help > About in the RealPlayer menu.


Handheld Devices
Software Affected? Language Update Needed?
Nokia Series60 Handsets No English No
RealPlayer for Palm No English No
RealOne Player for Palm No English No

Instructions


Windows Players:

If you are on Windows Vista, please click here to download a new player from the web.

RealOne Player (English only), RealOne Player V2, RealPlayer 10 and RealPlayer 10.5 customers require a full download to correct this issue. Please click here or use the following steps to upgrade your Player:

  1. In the Tools menu select Check for Update.
  2. Select the box next to the "RealPlayer 10.5 with Harmony™ Technology" component.
  3. Click Install to download and install the update.

RealPlayer 8 (version 6.0.9.584) customers please click here or use the following steps to upgrade your Player:

  1. Go the Help menu.
  2. Select Check for Update.
  3. Select the box next to the "RealPlayer 10.5 with Harmony™ Technology" component.
  4. Click Install to download and install the update.


RealPlayer Enterprise Solution:

Please click here to get information on upgrading your RealPlayer Enterprise.

RealPlayer for Mac OS X:

RealPlayer 10 for Mac OS X and RealOne Player for Mac OSX customers need to get the latest player to address this security issue. Please click here to upgrade your Player.


Linux Players:

Please click here to get an updated RealPlayer 10 for Linux.
Please click here to get an updated Helix Player for Linux.

Details for Potential Vulnerabilities:

  • Vulnerability 1:
    The identified vulnerability is a malicious mp3 file which could cause a heap overflow in the RealPlayer. CVE-2007-5080

  • Vulnerability 2:
    The identified vulnerability is a malicious rm file which could cause a heap overflow in the RealPlayer. CVE-2007-5081

  • Vulnerability 3:
    The identified vulnerability is a malicious SMIL file which could cause a buffer overflow in the RealPlayer. CVE-2007-3410

  • Vulnerability 4:
    The identified vulnerability is a malicious swf file (flash media) which could cause a heap overflow on a customer's machine. CVE-2007-2263

  • Vulnerability 5:
    The identified vulnerability is a malicious ram file which could cause a heap overflow in the RealPlayer. CVE-2007-2264

  • Vulnerability 6:
    The identified vulnerability is a malicious pls file which could cause a stack overflow in the RealPlayer. CVE-2007-4599


German
English
Spanish
French
Italian
Portuguese
Japanese
Korean
Simplified Chinese
Traditional Chinese


Acknowledgements:

RealNetworks would like to acknowledge John Heasman of NGS Software, Piotr Bania, and anonymous researchers working with TippingPoint and the Zero Day Initiative for bringing these exploits to our attention as well as those who subsequently worked with RealNetworks to correct the vulnerabilities.

Warranty:

RealNetworks Inc. endeavors to provide you with the highest quality products and services, but cannot guarantee, and does not warrant, that the operation of any RealNetworks product will be error-free, uninterrupted or secure. Please see your original license agreement for details of our limited warranty or warranty disclaimer.